---
id: "CVE-2026-17327"
page: "https://infrastack.ai/live/CVE-2026-17327"
kind: "vulnerability"
aliases: ["CVE-2026-17327"]
title: "IBM API Connect 12.1: authenticated SSRF lets a low-privileged user read sensitive information; fixed in 12.1.1.3"
severity: "high"
cvss: 8.5
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "authenticated", "ibm-api-connect", "self-hosted", "vendor"]
not_affected_if: ["auth-required", "outside-affected-range"]
published_at: "2026-11-07T05:18:42+00:00"
first_seen_at: "2026-11-07T05:46:03+00:00"
updated_at: "2026-11-07T06:17:36+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17327", "first_seen_at": "2026-11-07T05:46:03+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:17:36+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect 12.1: authenticated SSRF lets a low-privileged user read sensitive information; fixed in 12.1.1.3

Link for people: https://infrastack.ai/live/CVE-2026-17327 (this .md is for agents)

IBM says API Connect could let a remote authenticated attacker obtain sensitive information through server-side request forgery (CWE-918, CVSS 8.5). It affects V12 OnPrem v12.1.0.0-v12.1.1.2 and is fixed in v12.1.1.3. IBM lists no workarounds.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 OnPrem version. Versions v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 is fixed. IBM does not name the vulnerable endpoint.

## Fix

Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205). IBM lists no workarounds.

## Timeline

- 2026-11-07T05:46:03+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17327
- 2026-11-07T06:17:36+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Read IBM bulletin (node -39, 2026-11-05): CVE-2026-17327 SSRF, CVSS 8.5 (PR:L, scope changed, C:H), affects API Connect V12 OnPrem v12.1.0.0-v12.1.1.2, fixed v12.1.1.3, no workarounds. Bulletin does not name the endpoint or the role; no exploitation or PoC stated.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
