IBM API CONNECT V12 ONPREM · CVE-2026-17316 · Runtime
FIX → 12.1.1.3 ✓ verified
IBM API Connect 12.1.0.0 through 12.1.1.2 does not properly validate user-supplied input. A remote attacker can make the server send requests to destinations of their choosing.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 (on-prem) at v12.1.0.0 through v12.1.1.2. A remote attacker needs no authentication (CVSS PR:N) and can make the server send requests to destinations the attacker picks. IBM does not name the endpoint or feature involved. Versions at v12.1.1.3 or later can skip it.
Not affected if unaffected-version
Who cares ibm-api-connect, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 is the fixed releaseIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to perform server-side request forgery due to improper validation of user-supplied input.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)