API CONNECT V12 ONPREM · CVE-2026-17278 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM says API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 does not sufficiently verify client-supplied information, so a remote unauthenticated caller can appear as a trusted party and read sensitive API catalog and runtime configuration data. Fixed in v12.1.1.3; IBM lists no workaround.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted IBM API Connect V12 OnPrem deployments on v12.1.0.0 through v12.1.1.2 are exposed; IBM rates it 9.8 with network access and no privileges needed. Teams on 10.0.8.x are not listed for this CVE in the bulletin. Upgrade to v12.1.1.3.
Not affected if unknown
Who cares api-gateway, authentication-bypass, ibm-api-connect, self-hosted
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fix10.0.8.x line is not listed for this CVE in IBM's bulletinIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to gain unauthorized access to sensitive API catalog and runtime configuration data due to improper authentication. Information supplied by the client is not sufficiently verified, which could allow a caller to appear as a trusted party.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central, see IBM node 7290205)