---
id: "CVE-2026-17278"
page: "https://infrastack.ai/live/CVE-2026-17278"
kind: "vulnerability"
aliases: ["CVE-2026-17278"]
title: "IBM API Connect 12.1.0.0-12.1.1.2: remote caller can pass as a trusted party and read API catalog and runtime configuration data"
severity: "critical"
cvss: 9.8
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "authentication-bypass", "ibm-api-connect", "self-hosted", "vendor"]
not_affected_if: ["unknown"]
published_at: "2026-11-07T05:18:33+00:00"
first_seen_at: "2026-11-07T05:46:01+00:00"
updated_at: "2026-11-07T05:58:26+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17278", "first_seen_at": "2026-11-07T05:46:01+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T05:58:26+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "https://www.ibm.com/support/pages/node/7290205"]}]
exploit_sources: []
---

# IBM API Connect 12.1.0.0-12.1.1.2: remote caller can pass as a trusted party and read API catalog and runtime configuration data

Link for people: https://infrastack.ai/live/CVE-2026-17278 (this .md is for agents)

IBM says API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 does not sufficiently verify client-supplied information, so a remote unauthenticated caller can appear as a trusted party and read sensitive API catalog and runtime configuration data. Fixed in v12.1.1.3; IBM lists no workaround.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 OnPrem version. Versions v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fix. The 10.0.8.x line is not listed for this CVE in IBM's bulletin.

## Fix

Upgrade IBM API Connect to v12.1.1.3 (Fix Central, see IBM node 7290205). IBM lists no workaround.

## Timeline

- 2026-11-07T05:46:01+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17278
- 2026-11-07T05:58:26+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — IBM bulletin (api-connect-39) lists CVE-2026-17278 (CWE-290, IBM CVSS 9.8, AV:N/PR:N): affected API Connect V12 OnPrem v12.1.0.0-v12.1.1.2, fix v12.1.1.3, workarounds none. Exploitation/PoC and social chatter not checked.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39
- [fix] IBM API Connect v12.1.1.3 is now available https://www.ibm.com/support/pages/node/7290205

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to gain unauthorized access to sensitive API catalog and runtime configuration data due to improper authentication. Information supplied by the client is not sufficiently verified, which could allow a caller to appear as a trusted party.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
