IBM API CONNECT V12 ONPREM · CVE-2026-17188 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 fetch external resources referenced in imported service definitions without enough restriction. A remote attacker with an account can make the server request internal or unintended resources and obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 (OnPrem) v12.1.0.0 through v12.1.1.2. An attacker needs a valid account, then imports a service definition whose external references make the server request internal or unintended resources and return sensitive data. IBM's bulletin lists only V12 OnPrem; others can skip it.
Not affected if auth-required, outside-affected-range
Who cares ibm-api-connect, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 is fixedIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery. When service definitions are imported, references to external resources are not sufficiently restricted, so the server could be made to request resources it should not access.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)