API CONNECT V12 ONPREM · CVE-2026-17187 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 do not properly validate user-supplied URLs. A remote attacker with an account can use this to obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running IBM API Connect V12 on-premises, versions 12.1.0.0 through 12.1.1.2. IBM describes it as improper validation of a user-supplied URL (server-side request forgery) that lets a logged-in remote user obtain sensitive information; the bulletin does not say which URL inputs are affected. IBM's table lists only V12 OnPrem; the 10.0.8.x line is not listed for this CVE in that bulletin.
Not affected if auth-required, version-outside-range
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fixIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper validation of user-supplied URLs.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)