---
id: "CVE-2026-17187"
page: "https://infrastack.ai/live/CVE-2026-17187"
kind: "vulnerability"
aliases: ["CVE-2026-17187"]
title: "IBM API Connect: flawed URL validation leaks sensitive information to logged-in users"
severity: "high"
cvss: 8.5
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "authenticated", "ibm-api-connect", "infrastructure", "self-hosted", "ssrf"]
not_affected_if: ["auth-required", "version-outside-range"]
published_at: "2026-11-07T05:18:29+00:00"
first_seen_at: "2026-11-07T05:45:59+00:00"
updated_at: "2026-11-07T06:24:07+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17187", "first_seen_at": "2026-11-07T05:45:59+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:24:07+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect: flawed URL validation leaks sensitive information to logged-in users

Link for people: https://infrastack.ai/live/CVE-2026-17187 (this .md is for agents)

IBM API Connect versions 12.1.0.0 through 12.1.1.2 do not properly validate user-supplied URLs. A remote attacker with an account can use this to obtain sensitive information.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 on-prem version. Versions v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fix. IBM lists no workarounds.

## Fix

Upgrade IBM API Connect to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)

## Timeline

- 2026-11-07T05:45:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17187
- 2026-11-07T06:24:07+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — IBM bulletin (api-connect-39, 2026-11-05) lists CVE-2026-17187 as SSRF (CWE-918), CVSS 8.5; affected API Connect V12 OnPrem v12.1.0.0-v12.1.1.2, fixed in v12.1.1.3; no workarounds. Bulletin text truncated by tools; CVE entry read via page summarizer, the affected/fix sections read from page tail. Which URL inputs are affected is not stated. No X check.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper validation of user-supplied URLs.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
