API CONNECT · CVE-2026-16880 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a path traversal flaw. A logged-in remote attacker can use it to obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Organisations running IBM API Connect in the affected version ranges, where remote users hold valid accounts. The sources do not describe the specific endpoint or configuration involved. unknown for further detail.
Not affected if unaffected-version
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12 and 12.1.0.0 to 12.1.1.210.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to path traversal.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8.x) or 12.1.1.3 (12.1.x) via IBM Fix Central