API CONNECT · CVE-2026-17378 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to check object-level authorization. A remote attacker with a valid account can read sensitive information belonging to other objects.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2 (IBM's V12 table lists OnPrem) are exposed. An attacker needs a valid account on the platform, then can read sensitive information belonging to other objects because of broken object-level authorization (CWE-639 in the v12.1 bulletin, CWE-863 in the 10.0.8 bulletin). Deployments on 10.0.8.13 or 12.1.1.3 or later can skip it.
Not affected if fixed-version, version-outside-range
Who cares api-connect, ibm, self-hosted
10.0.8.0 through 10.0.8.12, or (V12 OnPrem) 12.1.0.0 through IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to broken object-level authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and v12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line)