---
id: "CVE-2026-17378"
page: "https://infrastack.ai/live/CVE-2026-17378"
kind: "vulnerability"
aliases: ["CVE-2026-17378"]
title: "IBM API Connect: broken authorization exposes sensitive data to logged-in users"
severity: "high"
cvss: 7.7
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "API Connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}, {"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-connect", "ibm", "infrastructure", "self-hosted"]
not_affected_if: ["fixed-version", "version-outside-range"]
published_at: "2026-11-07T05:18:51+00:00"
first_seen_at: "2026-11-07T05:46:06+00:00"
updated_at: "2026-11-07T06:10:11+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17378", "first_seen_at": "2026-11-07T05:46:06+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:10:11+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41"]}]
exploit_sources: []
---

# IBM API Connect: broken authorization exposes sensitive data to logged-in users

Link for people: https://infrastack.ai/live/CVE-2026-17378 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 fail to check object-level authorization. A remote attacker with a valid account can read sensitive information belonging to other objects.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13
- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect version. Exposed if it is 10.0.8.0 through 10.0.8.12, or (V12 OnPrem) 12.1.0.0 through 12.1.1.2. Fixed in 10.0.8.13 and v12.1.1.3.

## Fix

Upgrade to IBM API Connect 10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line). IBM lists no workaround.

## Timeline

- 2026-11-07T05:46:06+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17378
- 2026-11-07T06:10:11+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Read both IBM bulletins (-39 for v12.1.1.3, -41 for 10.0.8.13); CVE listed in each, no workarounds, no exploitation reported. The 10.0.8 page metadata says V10.0.8.0-V10.0.8.13 but its table and text say .12 and the fix is .13.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to broken object-level authorization.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
