API CONNECT V12 ONPREM · CVE-2026-17353 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A signed-in remote attacker can make the server send requests on their behalf, which can expose sensitive information and bypass security restrictions.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed (on-prem) IBM API Connect V12, versions 12.1.0.0 through 12.1.1.2, where any authenticated user (even low-privilege) can reach the product. The flaw lets that user make the server send requests on their behalf, exposing sensitive data and bypassing restrictions. The 10.0.8.x line is not listed for this CVE in IBM's bulletins; those on 12.1.1.3 or later can skip it.
Not affected if unknown
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 is fixed10.0.8.x line is not listed for this CVEIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information and bypass security restrictions due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)