API CONNECT V12 ONPREM · CVE-2026-17352 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 has a server-side request forgery flaw (CVSS 8.5). A user with a valid account can make the server send requests and read back sensitive information. IBM fixes it in v12.1.1.3 and lists no workaround.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2. An attacker needs a valid account and can make the server send requests and get back sensitive information. IBM's bulletin does not name the feature that is affected. Teams on v12.1.1.3 or later can skip it.
Not affected if outside-affected-range, v12.1.1.3-or-later
Who cares api-gateway, ibm-api-connect, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fix10.0.8.xIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)