API CONNECT V12 ONPREM · CVE-2026-17343 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 fail to enforce proper authorization checks. A remote attacker with a valid account can read or modify sensitive information they should not reach.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 (on-prem) v12.1.0.0 through v12.1.1.2. Any user with a valid account can reach the flaw over the network (CWE-863 incorrect authorization) and read or modify data they should not access. IBM lists no workaround. Skip if you are on v12.1.1.3 or later.
Not affected if unknown
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
v12.1.0.0 through v12.1.1.2v12.1.1.3IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass authorization checks to access or modify sensitive information due to improper authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)