API CONNECT V12 ONPREM · CVE-2026-17341 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 fail to neutralize user-supplied input properly. A remote attacker can make the server send requests to other systems and relay unauthorized email messages.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 are affected. IBM describes an unauthenticated remote attacker abusing user-supplied input to make the server send requests and relay unauthorized email. The bulletin names no required setting. IBM lists no workaround. Anyone on v12.1.1.3 or later can skip it.
Not affected if unknown
Who cares api-gateway, ibm-api-connect, self-hosted
v12.1.0.0 through v12.1.1.2 are affected. v12.1.1.3 is the fixed versionIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to perform server-side request forgery and relay unauthorized email messages due to improper neutralization of user-supplied input.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)