API CONNECT V12 ONPREM · CVE-2026-17340 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 contain a path traversal flaw that lets a remote attacker escape intended file locations. The flaw can lead to arbitrary code execution on the affected server.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running IBM API Connect V12 OnPrem, versions v12.1.0.0 through v12.1.1.2. IBM rates it 9.8: a remote attacker needs no login and no user interaction, and a path traversal can lead to arbitrary code execution. Other API Connect lines (e.g. 10.0.8.x) are covered by separate IBM bulletins and are not listed for this CVE; anyone not running API Connect V12 can skip it.
Not affected if version-outside-range
Who cares api-gateway, ibm-api-connect, on-prem, path-traversal, unauthenticated
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to execute arbitrary code due to a path traversal vulnerability.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)