API CONNECT V12 ONPREM · CVE-2026-17338 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 does not enforce object-level authorization, so a remote authenticated attacker can obtain sensitive information. IBM rates it CVSS 9.1 and fixes it in v12.1.1.3.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect V12 OnPrem, versions v12.1.0.0 to v12.1.1.2, where any logged-in user with low privileges can reach the API. Broken object-level authorization lets that user read sensitive data they should not see. IBM lists no workaround; teams on v12.1.1.3 or later, or on offerings not named in the bulletin, can skip it.
Not affected if unknown, v12.1.1.3-or-later
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 contains the fixIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to broken object-level authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)