API CONNECT V12 ONPREM · CVE-2026-17334 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect 12.1.0.0 through 12.1.1.2 has an improper authorization flaw driven by user-controlled keys. A remote attacker with a valid account can obtain sensitive information they should not see.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect V12 on-premises, versions 12.1.0.0 through 12.1.1.2. An attacker needs a valid account, then can read information they should not see by manipulating user-controlled keys (CWE-639). IBM's bulletin does not name the endpoints. Other API Connect lines are not listed in this bulletin.
Not affected if auth-required, no-authenticated-remote-users, unaffected-version
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted
Check your IBM API Connect V12 on-prem version; versions v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 is fixed.
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper authorization via user-controlled keys.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)