API CONNECT · CVE-2026-17333 · Vendor
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not validate certificates properly. A remote attacker can bypass authentication and push unauthorized configuration changes.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed (on-prem) IBM API Connect 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. IBM scores this CVSS 8.0 with an adjacent-network vector (AV:A, high complexity, no privileges): the attacker needs network adjacency to the API Connect components, not necessarily the internet. IBM lists no workaround; other versions can skip it.
Not affected if 10.0.8.13-or-later, 12.1.1.3-or-later, other-versions
Who cares adjacent-network, api-gateway, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, and 12.1.0.0 through (IBM lists )IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to bypass authentication and inject unauthorized configuration changes due to improper certificate validation.
This page as .md · .json · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.2API Connect V12 OnPrem10.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line)