---
id: "CVE-2026-17333"
page: "https://infrastack.ai/live/CVE-2026-17333"
kind: "vulnerability"
aliases: ["CVE-2026-17333"]
title: "IBM API Connect: certificate validation flaw lets remote attackers bypass authentication"
severity: "high"
cvss: 8.0
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "API Connect", "fixed": ["10.0.8.13"], "affected": ">= 10.0.8.0, <= 10.0.8.12", "ecosystem": "vendor"}, {"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["adjacent-network", "api-gateway", "ibm-api-connect", "self-hosted", "vendor"]
not_affected_if: ["10.0.8.13-or-later", "12.1.1.3-or-later", "other-versions"]
published_at: "2026-11-07T05:18:44+00:00"
first_seen_at: "2026-11-07T05:46:04+00:00"
updated_at: "2026-11-07T06:15:25+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17333", "first_seen_at": "2026-11-07T05:46:04+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:15:25+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41"]}]
exploit_sources: []
---

# IBM API Connect: certificate validation flaw lets remote attackers bypass authentication

Link for people: https://infrastack.ai/live/CVE-2026-17333 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not validate certificates properly. A remote attacker can bypass authentication and push unauthorized configuration changes.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect affected >= 10.0.8.0, <= 10.0.8.12 fixed 10.0.8.13
- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect version. Affected: 10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.2 (IBM lists 'API Connect V12 OnPrem'). Fixed: 10.0.8.13 and 12.1.1.3.

## Fix

Upgrade to API Connect 10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line). Fix Central: https://www.ibm.com/support/pages/node/7290205 (12.1).

## Timeline

- 2026-11-07T05:46:04+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17333
- 2026-11-07T06:15:25+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — IBM bulletins (-41 for 10.0.8.13, -39 for v12.1.1.3) list CVE-2026-17333, CWE-295, CVSS 8.0 AV:A; workarounds None. No exploitation or PoC seen (not searched on X). Offseq claimed no fix; IBM says fixed.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to bypass authentication and inject unauthorized configuration changes due to improper certificate validation.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
