API CONNECT V12 ONPREM · CVE-2026-17330 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A remote attacker with a valid account can make the server send requests on their behalf and obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 OnPrem, v12.1.0.0 through v12.1.1.2. An attacker needs a valid low-privilege account; they can make the server send requests on their behalf and read sensitive data (IBM CVSS 8.5, scope changed). The bulletin lists only API Connect V12 OnPrem as affected.
Not affected if auth-required, outside-version-range
Who cares api-gateway, ibm-api-connect, self-hosted
Check your installed API Connect V12 OnPrem version. v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fix.
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)