API CONNECT V12 ONPREM · CVE-2026-17329 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM says API Connect V12 OnPrem v12.1.0.0 to v12.1.1.2 does not properly validate endpoint URLs (CWE-918, server-side request forgery). A remote attacker with no login can obtain sensitive information. IBM rates it CVSS 9.3.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed (OnPrem) IBM API Connect V12, versions v12.1.0.0 to v12.1.1.2. IBM rates the flaw as exploitable over the network with no login, so any instance reachable by an attacker should be treated as exposed; the bulletin does not say which data leaks. Teams on v12.1.1.3 or later, or on other API Connect offerings not named in the bulletin, can skip it.
Not affected if v12.1.1.3-or-later
Who cares api-gateway, ibm-api-connect, pre-auth, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 contains the fixIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to improper validation of endpoint URLs.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)