API CONNECT V12 ONPREM · CVE-2026-17328 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect V12 OnPrem v12.1.0.0 through v12.1.1.2 has incomplete input checks (IBM maps it to server-side request forgery, CWE-918) that a logged-in remote attacker can bypass to read sensitive information. IBM fixed it in v12.1.1.3 and lists no workarounds.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect V12 OnPrem, versions v12.1.0.0 through v12.1.1.2. An attacker needs a valid account (remote, low privilege), so exposure depends on who can log in to the platform; IBM classes the flaw as server-side request forgery, where the server can be made to fetch content it should not return. IBM lists only the V12 OnPrem product in this bulletin, so other API Connect lines are not confirmed affected.
Not affected if fixed-v12.1.1.3, outside-affected-range
Who cares api-connect, api-gateway, ibm, self-hosted
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 or later is fixedIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper input validation. Input checks are incomplete, which could allow them to be bypassed.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)