API CONNECT V12 ONPREM · CVE-2026-17311 · Infrastructure
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 have a broken object-level authorization flaw. A logged-in remote user can change application API subscriptions that belong to other applications.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams that run IBM API Connect V12 on-premises, versions 12.1.0.0 to 12.1.1.2. Any logged-in user could change API subscriptions that belong to other applications. Skip it if you are on 12.1.1.3 or later; IBM's bulletin lists only the V12 OnPrem product for this range.
Not affected if auth-required, other-versions, unauthenticated-only-access
Who cares api-gateway, auth-required, ibm-api-connect, self-hosted
v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 is fixedIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to modify application API subscriptions due to broken object-level authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)