API CONNECT · CVE-2026-17279 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
Certain requests to IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 can stall internal processing from uncontrolled resource consumption. A remote attacker with valid credentials can make the service unavailable.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted IBM API Connect installs on 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. An attacker needs valid credentials (low privilege, network access) and can send requests that stall internal processing and make the service unavailable. No data exposure is stated; teams whose API Connect accounts are limited to trusted staff can treat this as lower priority.
Not affected if unaffected-version
Who cares api-gateway, authenticated, denial-of-service, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, and 12.1.0.0 through 12.1.1.2 (IBM lists V12 OnPrem)10.0.8.13 and 12.1.1.3IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to cause a denial of service due to uncontrolled resource consumption. Certain requests can cause internal processing to stall, which could make the service unavailable.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8 line) or v12.1.1.3 (12.1 line)