API CONNECT V12 ONPREM · CVE-2026-17239 · Vendor
FIX → v12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 contain a path traversal flaw. A remote attacker with a valid account can use it to execute arbitrary code.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Organizations running IBM API Connect 12.1.0.0 through 12.1.1.2 where users can authenticate to the platform. The sources do not describe specific configurations, so the exact exposure is unknown.
Not affected if unknown
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
Check installed API Connect V12 on-prem version; v12.1.0.0 through v12.1.1.2 are affected, v12.1.1.3 is fixed.
Upgrade to v12.1.1.3
IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code due to a path traversal vulnerability.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)