API CONNECT V12 ONPREM · CVE-2026-17131 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 can be made to send requests to destinations it should not reach, because outbound request restrictions can be bypassed. An remote attacker can use the server to fetch internal responses and obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted (OnPrem) IBM API Connect V12 installs running v12.1.0.0 through v12.1.1.2. IBM's description says a remote attacker can exploit it, and the CVSS vector says no authentication or user interaction is needed (PR:N). The server can be made to contact unintended destinations and return the response, because outbound request restrictions can be bypassed. Teams on other versions, or not using API Connect, can skip it; this bulletin lists only V12 OnPrem.
Not affected if outside-affected-version-range
Who cares ibm-api-connect, self-hosted, ssrf
v12.1.0.0 through v12.1.1.2 are affected; v12.1.1.3 contains the fixIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to server-side request forgery. Restrictions on outbound requests can be bypassed, so the server could be made to contact unintended destinations and return the response.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)