API CONNECT V12 ONPREM · CVE-2026-16717 · Vendor
FIX → 12.1.1.3 ✓ verified
IBM API Connect versions 12.1.0.0 through 12.1.1.2 have a broken object-level authorization flaw. A logged-in user can request objects they do not own and obtain sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-hosted IBM API Connect V12 OnPrem 12.1.0.0 through 12.1.1.2 where users have valid accounts. A logged-in user can request objects they do not own and read sensitive information (broken object-level authorization, CWE-639). Versions 12.1.1.3 and later, and the 10.0.8 stream (not listed for this CVE), can skip it.
Not affected if outside-affected-version-range, unaffected-version
Who cares api-gateway, ibm-api-connect, self-hosted
v12.1.0.0 to v12.1.1.2, fixed in v12.1.1.310.0.8.x stream is not listed for this CVE in the bulletinIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to broken object-level authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 12.1.1.3
v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205)