API CONNECT · CVE-2026-17318 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM says API Connect could let a remote authenticated attacker obtain sensitive information due to improper authorization (CWE-639, user-controlled key; CVSS 7.7, AV:N/AC:L/PR:L). Affected: V10.0.8.0-10.0.8.12 and V12 OnPrem v12.1.0.0-v12.1.1.2. Fixed in 10.0.8.13 and v12.1.1.3. IBM lists no workarounds. No exploitation or PoC stated. IBM does not name the endpoint or data exposed.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Self-hosted IBM API Connect on 10.0.8.0-10.0.8.12 or V12 OnPrem 12.1.0.0-12.1.1.2 is exposed to any logged-in user, who could read information they should not see through a flaw in authorization checks. Look at deployments where untrusted or multi-tenant users hold API Connect accounts. Deployments already on 10.0.8.13 or 12.1.1.3 can skip it.
Not affected if auth-required, outside-affected-range, version-outside-range
Who cares api-gateway, authenticated, ibm-api-connect, self-hosted
10.0.8.0 through 10.0.8.12, and V12 OnPrem 12.1.0.0 through IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper authorization.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (V10 line) or v12.1.1.3 (V12 OnPrem; Fix Central: https://www.ibm.com/support/pages/node/7290205)