API CONNECT · CVE-2026-17289 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a server-side request forgery flaw. A logged-in attacker can make the server fetch internal resources and return sensitive information.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. Any logged-in user can make the server send requests to internal resources and read back sensitive information. IBM lists no workaround, so upgrading is the only remedy. Teams not running API Connect can skip it.
Not affected if unaffected-version, unauthenticated-only-access, versions-outside-range
Who cares ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12 and 12.1.0.0 to 12.1.1.2IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
10.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
Upgrade to API Connect 10.0.8.13 (10.0.8.x) or 12.1.1.3 (12.1.x).