API CONNECT · CVE-2026-17172 · Infrastructure
FIX → 10.0.8.13 · 12.1.1.3 ✓ verified
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 do not sufficiently verify client-supplied information during authentication. A remote attacker with a valid account can bypass security restrictions and impersonate another party. IBM rates it CVSS 8.5 (attack complexity high) and lists no workaround.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running self-managed IBM API Connect 10.0.8.0-10.0.8.12 or 12.1.0.0-12.1.1.2. A logged-in user could pass off another party's identity because client-supplied information is not sufficiently verified; IBM rates the attack as high complexity. IBM lists no workaround, so upgrading is the only remedy. Teams not running API Connect can skip it.
Not affected if unaffected-version, version-outside-affected-ranges
Who cares api-gateway, ibm-api-connect, self-hosted
10.0.8.0 to 10.0.8.12 and 12.1.0.0 to (V12 OnPrem per IBM)IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions due to improper authentication. Information supplied by the client is not sufficiently verified, which could allow a caller to impersonate another party.
This page as .md · .json · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
12.1.1.210.0.8.13 and 12.1.1.3Upgrade to 10.0.8.13 · 12.1.1.3
10.0.8.13 (10.0.8.x) or 12.1.1.3 (12.1.x), via IBM Fix Central