Live › vulnerability › GHSA-593v-wcqx-hq2w
Parse Server's git repository received incorrect version tags that linked to code in a contributor's personal fork, which Parse Platform never reviewed. Anyone who pinned a git dependency to one of these tags, including users of the Bitnami Parse Server image, may run code that was not approved, and the sources cannot rule out security flaws in it.
Summary written from the sources below. Check the originals before acting.
First seen by InfraStack 2026-11-02 18:37 UTC. All times on this page are UTC.
Projects that depend on parse-server in the affected ranges, especially those that pinned it to a git tag such as 4.9.3 instead of a published npm release. Teams running the Bitnami Parse Server image built from the bad tag are also named as affected. Projects that install parse-server from npm registry releases with a normal version range and never used the listed tags are not exposed by this flaw.
| Product | Ecosystem | Affected | Fixed in |
|---|---|---|---|
| parse-server | npm | >= 4.0.0, < 4.5.2 | 4.5.2 |
| parse-server | npm | >= 4.6.0, < 4.10.0 | 4.10.0 |
npm ls parse-serverpackage.json (for example a style reference)git+...#4.9.3parse-server to 4.10.0 for the affected 4.6.0 to below 4.10.0 rangeparse-server to 4.5.2 for the affected 4.0.0 to below 4.5.2 range (the sources list 4.5.2 as the fixed version for that range, while also suggesting a downgrade to 4.5.2 as a workaround; the advisory recommends 4.10.0)Each row is the first time that source carried this signal. The analyst’s rows are its own findings.
A security incident caused a number of incorrect version tags to be pushed to the Parse Server repository. These version tags linked to a personal fork of a contributor who had write access to the repository. The code to which these tags linked has not been reviewed or approved by Parse Platform. Even though no releases were published with these incorrect versions, it was possible to define a Parse Server dependency that pointed to these version tags, for example if you defined this dependency:
"parse-server": "[email protected]:parse-community/parse-server.git#4.9.3"
We have since deleted the incorrect version tags, but they may still show up in your personal fork on GitHub or locally. We do not know when these tags have been pushed to the Parse Server repository, but we first became aware of this issue on July 21, 2021. We are not aware of any malicious code or concerns related to privacy, security or legality (e.g. proprietary code). However, it has been reported that some functionality does not work as expected and the introduction of security vulnerabilities cannot be ruled out.
You may be also affected if you used the Bitnami image for Parse Server. Bitnami picked up the incorrect version tag 4.9.3 and published a new Bitnami image for Parse Server.
If you are using any of the affected versions, we urgently recommend to upgrade to version 4.10.0.
These are the incorrect tags:
4.0.0-beta1
4.0.0-beta2
4.0.0-beta3
4.0.0-beta4
4.0.0-beta5
4.0.0-beta6
4.0.10
4.0.11
4.0.12
4.0.13
4.0.14
4.0.3
4.0.4
4.0.6
4.0.7
4.0.8
4.0.9
4.6.0
4.6.0-beta
4.7.0
4.8.0
4.8.1
4.8.2
4.8.3
4.8.4
4.8.5
4.9.0
4.9.1
4.9.2
4.9.3
Upgrade to version 4.10.0.
Downgrade to version 4.5.2.
n/a
This page as .md · .json · in your agent: get_signal("GHSA-593v-wcqx-hq2w")
GitHub Advisory Database, CC-BY 4.0. Posts quoted belong to their authors.