---
id: "GHSA-593v-wcqx-hq2w"
kind: "vulnerability"
aliases: ["GHSA-593v-wcqx-hq2w"]
title: "Incorrect version tags linked to external repository"
severity: "high"
cvss: 7.5
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "parse-server", "fixed": ["4.5.2"], "affected": ">= 4.0.0, < 4.5.2", "ecosystem": "npm"}, {"name": "parse-server", "fixed": ["4.10.0"], "affected": ">= 4.6.0, < 4.10.0", "ecosystem": "npm"}]
ecosystems: ["npm"]
tags: ["bitnami", "cwe-484", "cwe-494", "node.js", "npm", "package", "parse-server"]
not_affected_if: ["no-git-dependency", "published-npm-releases-only"]
published_at: "2021-09-07T22:57:58+00:00"
first_seen_at: "2026-11-02T18:37:09+00:00"
updated_at: "2026-11-02T18:39:02+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-593v-wcqx-hq2w", "first_seen_at": "2026-11-02T18:37:09+00:00"}]
---

# Incorrect version tags linked to external repository

Parse Server's git repository received incorrect version tags that linked to code in a contributor's personal fork, which Parse Platform never reviewed. Anyone who pinned a git dependency to one of these tags, including users of the Bitnami Parse Server image, may run code that was not approved, and the sources cannot rule out security flaws in it.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- npm:parse-server affected >= 4.0.0, < 4.5.2 fixed 4.5.2
- npm:parse-server affected >= 4.6.0, < 4.10.0 fixed 4.10.0

## How to check

- Check the installed version with `npm ls parse-server`
- Look for git-based dependencies on parse-server in `package.json` (for example a `git+...#4.9.3` style reference)
- If you run the Bitnami Parse Server image, check which image tag and version it was built from

## Fix

- Upgrade `parse-server` to `4.10.0` for the affected 4.6.0 to below 4.10.0 range
- Upgrade `parse-server` to `4.5.2` for the affected 4.0.0 to below 4.5.2 range (the sources list 4.5.2 as the fixed version for that range, while also suggesting a downgrade to 4.5.2 as a workaround; the advisory recommends 4.10.0)

## Timeline

- 2026-11-02T18:37:09+00:00 ghsa https://github.com/advisories/GHSA-593v-wcqx-hq2w

## Documents

- [advisory] Maintainer's advisory: api.github.com https://api.github.com/repos/parse-community/parse-server/security-advisories/GHSA-593v-wcqx-hq2w
- [advisory] Maintainer's advisory: github.com https://github.com/parse-community/parse-server/security/advisories/GHSA-593v-wcqx-hq2w

## From the sources

### Impact
A security incident caused a number of incorrect version tags to be pushed to the Parse Server repository. These version tags linked to a personal fork of a contributor who had write access to the repository. The code to which these tags linked has not been reviewed or approved by Parse Platform. Even though no releases were published with these incorrect versions, it was possible to define a Parse Server dependency that pointed to these version tags, for example if you defined this dependency: 
```js
"parse-server": "git@github.com:parse-community/parse-server.git#4.9.3"
```

We have since deleted the incorrect version tags, but they may still show up in your personal fork on GitHub or locally. We do not know when these tags have been pushed to the Parse Server repository, but we first became aware of this issue on July 21, 2021. We are not aware of any malicious code or concerns related to privacy, security or legality (e.g. proprietary code). However, it has been reported that some functionality does not work as expected and the introduction of security vulnerabilities cannot be ruled out.

You may be also affected if you used the Bitnami image for Parse Server. Bitnami picked up the incorrect version tag `4.9.3` and published a new Bitnami image for Parse Server. 
 
**If you are using any of the affected versions, we urgently recommend to upgrade to version `4.10.0`.**


These are the incorrect tags:
```
4.0.0-beta1
4.0.0-beta2
4.0.0-beta3
4.0.0-beta4
4.0.0-beta5
4.0.0-beta6
4.0.10
4.0.11
4.0.12
4.0.13
4.0.14
4.0.3
4.0.4
4.0.6
4.0.7
4.0.8
4.0.9
4.6.0
4.6.0-beta
4.7.0
4.8.0
4.8.1
4.8.2
4.8.3
4.8.4
4.8.5
4.9.0
4.9.1
4.9.2
4.9.3
```

### Patches
Upgrade to version `4.10.0`.

### Workarounds
Downgrade to version `4.5.2`.

### References
n/a

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
