IBM WATSON SPEECH SERVICES CARTRIDGE · CVE-2026-82418 · Vendor
FIX → 5.4.0 Patch 8 ✓ verified
IBM says Watson Speech Services Cartridge 4.0.0 through 5.4.0 is affected by a use-after-free in the OpenSSL bundled in the cryptography wheels (versions before 48.01) used by its Speech runtimes. Specially crafted PKCS#7 or S/MIME signed messages can trigger it during signature verification. IBM rates it 9.8 (network, no authentication, no user interaction) and says a remote attacker could execute arbitrary code. IBM lists no workarounds.
first public Nov 4, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams running IBM Watson Speech Services Cartridge versions 4.0.0 through 5.4.0 on Cloud Pak for Data or similar platforms are in scope. The sources do not say which deployment paths or configurations are exposed, so unknown.
Who cares cloud-pak-for-data, ibm-watson, openssl, self-hosted, speech-services
4.0.0 to 5.4.0 without 5.4.0 Patch 85.4.0 Patch 8, treat it as exposedIBM Watson Speech Services Cartridge 4.0.0 through 5.4.0 could allow a remote attacker to execute arbitrary code due to a use-after-free vulnerability.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 5.4.0 Patch 8
Install IBM Watson Speech Services Cartridge 5.4.0 Patch 8 (IBM says it applies to all versions 4.0.0-5.4.0): https://www.ibm.com/docs/en/cloud-paks/cp-data/5.4.x