CHURCH-ADMIN · CVE-2026-123418 · Package
FIX → 5.1.8 ✓ verified
The Church Admin WordPress plugin up to and including 5.1.7 does not sanitize the 'lat' parameter before storing and displaying it. An unauthenticated attacker can inject scripts into pages that run in the browser of anyone who opens the injected page.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Sites running the Church Admin plugin at version 5.1.7 or earlier with a Google Maps API key configured in its settings. The sources say the flaw is only reached when that key is present, so sites without it can skip it. The sources do not name a fixed version.
Not affected if no-google-maps-api-key, plugin-updated
Who cares church-admin, self-hosted, wordpress
Upgrade to 5.1.8
5.1.8 or later (WordPress admin > Plugins)The Church Admin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'lat' parameter in all versions up to, and including, 5.1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when a Google Maps API key has been configured in Church Admin settings, as the vulnerable sink is only reached when that option is present.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.