---
id: "CVE-2026-123418"
page: "https://infrastack.ai/live/CVE-2026-123418"
kind: "vulnerability"
aliases: ["CVE-2026-123418"]
title: "WordPress Church Admin plugin: unauthenticated stored script injection via lat parameter"
severity: "high"
cvss: 7.2
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "church-admin", "fixed": ["5.1.8"], "affected": "<= 5.1.7", "ecosystem": "wordpress"}]
ecosystems: []
tags: ["church-admin", "package", "self-hosted", "wordpress"]
not_affected_if: ["no-google-maps-api-key", "plugin-updated"]
published_at: "2026-11-07T12:17:45+00:00"
first_seen_at: "2026-11-07T12:47:09+00:00"
updated_at: "2026-11-07T12:50:13+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-123418", "first_seen_at": "2026-11-07T12:47:09+00:00"}, {"source": "analyst", "url": "https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/church-admin/church-admin-517-unauthenticated-stored-cross-site-scripting-via-lat-parameter", "first_seen_at": "2026-11-07T12:50:13+00:00", "cites": ["https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/church-admin/church-admin-517-unauthenticated-stored-cross-site-scripting-via-lat-parameter", "https://wordpress.org/plugins/church-admin/"]}]
exploit_sources: []
---

# WordPress Church Admin plugin: unauthenticated stored script injection via lat parameter

Link for people: https://infrastack.ai/live/CVE-2026-123418 (this .md is for agents)

The Church Admin WordPress plugin up to and including 5.1.7 does not sanitize the 'lat' parameter before storing and displaying it. An unauthenticated attacker can inject scripts into pages that run in the browser of anyone who opens the injected page.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress:church-admin affected <= 5.1.7 fixed 5.1.8

## How to check

- In WordPress admin > Plugins, check the Church Admin version; 5.1.7 and earlier are vulnerable, 5.1.8 is fixed.
- Check Church Admin settings for a Google Maps API key; Wordfence says the vulnerable code is only reached when one is configured.
- After updating, look for unfamiliar script or odd strings in saved address/map data and for unknown admin accounts.

## Fix

Update the Church Admin plugin to 5.1.8 or later (WordPress admin > Plugins). If you cannot update yet, remove the Google Maps API key from Church Admin settings or deactivate the plugin.

## Timeline

- 2026-11-07T12:47:09+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-123418
- 2026-11-07T12:50:13+00:00 analyst https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/church-admin/church-admin-517-unauthenticated-stored-cross-site-scripting-via-lat-parameter — Fixed in 5.1.8: maintainer changelog on wordpress.org ('Fix lat/lng XSS vulnerability'); Wordfence, Patchstack, WPScan agree. Only fix verified; affected range/precondition come from Wordfence, not the maintainer. No exploitation or PoC seen.

## Documents

- [advisory] Wordfence: Church Admin <= 5.1.7 stored XSS via lat https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/church-admin/church-admin-517-unauthenticated-stored-cross-site-scripting-via-lat-parameter
- [fix] Church Admin changelog (wordpress.org) https://wordpress.org/plugins/church-admin/

## From the sources

The Church Admin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'lat' parameter in all versions up to, and including, 5.1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when a Google Maps API key has been configured in Church Admin settings, as the vulnerable sink is only reached when that option is present.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
