---
id: "VND-nodejs-january-2025-security-releases"
kind: "vulnerability"
aliases: []
title: "Node.js: Tuesday, January 21, 2025 Security Releases"
severity: "high"
cvss: null
epss: null
exploited: false
status: "open"
category: "runtime"
products: [{"name": "node", "fixed": ["18.20.6"], "affected": ">= 18.0.0, < 18.20.6", "ecosystem": "node"}, {"name": "node", "fixed": ["20.18.2"], "affected": ">= 20.0.0, < 20.18.2", "ecosystem": "node"}, {"name": "node", "fixed": ["22.13.1"], "affected": ">= 22.0.0, < 22.13.1", "ecosystem": "node"}, {"name": "node", "fixed": ["23.6.1"], "affected": ">= 23.0.0, < 23.6.1", "ecosystem": "node"}]
ecosystems: ["node"]
tags: ["http2", "node", "node.js", "runtime", "self-hosted", "windows"]
not_affected_if: ["managed-hosting", "no-http2", "no-permission-model", "non-windows"]
published_at: "2025-01-21T03:00:00+00:00"
first_seen_at: "2026-10-23T19:13:00+00:00"
updated_at: "2026-10-25T05:39:31+00:00"
sources: [{"source": "nodejs", "url": "https://nodejs.org/en/blog/vulnerability/january-2025-security-releases", "first_seen_at": "2026-10-23T19:13:00+00:00"}]
---

# Node.js: Tuesday, January 21, 2025 Security Releases

Node.js 18, 20, 22 and 23 received security releases fixing three flaws: a worker permission bypass through diagnostics_channel (CVE-2025-23083, high), a Windows path traversal via drive names in path.join (CVE-2025-23084, medium), and a memory leak from HTTP/2 GOAWAY frames (CVE-2025-23085, medium). An attacker can escape the Permission Model, read or write files outside intended paths on Windows, or exhaust memory on an HTTP/2 server.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- node:node affected >= 18.0.0, < 18.20.6 fixed 18.20.6
- node:node affected >= 20.0.0, < 20.18.2 fixed 20.18.2
- node:node affected >= 22.0.0, < 22.13.1 fixed 22.13.1
- node:node affected >= 23.0.0, < 23.6.1 fixed 23.6.1

## How to check

- Run `node --version` and compare with the fixed versions below.
- If you use the Permission Model (`--permission`), check whether it is enabled in your startup flags or environment.
- On Windows services using `path.join` with user-supplied input, review that code path.
- Check whether your server exposes HTTP/2 (`http2.createServer` or `http2.createSecureServer`).

## Fix

- Upgrade Node.js 18.x to `18.20.6` or later.
- Upgrade Node.js 20.x to `20.18.2` or later.
- Upgrade Node.js 22.x to `22.13.1` or later.
- Upgrade Node.js 23.x to `23.6.1` or later.
- Node.js 17, 19 and 21 are end-of-life and receive no fixes; move to a supported release line.

## Timeline

- 2026-10-23T19:13:00+00:00 nodejs https://nodejs.org/en/blog/vulnerability/january-2025-security-releases

## From the sources

Commercial support for versions past the Maintenance LTS phase is available through our OpenJS Ecosystem Sustainability Program partners Tuesday, January 21, 2025 Security Releases TNJP The Node.js Project Tuesday, January 21, 2025 Security Releases Security releases available
Updates are now available for the 23.x, 22.x, 20.x, 18.x Node.js release lines for the
following issues.
This security release includes the following dependency updates to address public vulnerabilities:
undici (v7.2.3, v6.21.1, v5.28.5) on v23.x, v22.x, v20.x, v18.x.
Along with the security fixes, the Node.js team has also issued CVEs for
End-of-Life (EOL) versions of Node.js.
Node.js v17.x or prior CVE-2025-23087
Node.js v19.x CVE-2025-23088
Node.js v21.x CVE-2025-23089
More information in this blog post
Worker permission bypass via InternalWorker leak in diagnostics (CVE-2025-23083) - (high)
With the aid of the diagnostics_channel utility, an event can be hooked into whenever a worker thread is created. This is not limited only to workers but also exposes internal workers, where an instance of them can be fetched, and its constructor can be grabbed and reinstated for malicious usage.
This vulnerability affects Permission Model users (--permission) on Node.js v20, v22, and v23.
Impact:
This vulnerability affects all users in active release lines: 20.x, 22.x, 23.x
Thank you, to leodog896 for reporting this vulnerability and thank you RafaelGSS for fixing it.
Path traversal by drive name in Windows environment (CVE-2025-23084) - (medium)
A vulnerability has been identified in Node.js, specifically affecting the handling of drive names in the Windows environment. Certain Node.js functions do not treat drive names as special on Windows. As a result, although Node.js assumes a relative path, it actually refers to the root directory.
On Windows, a path that does not start with the file separator is treated as relative to the current directory.
This vulnerability affects Windows users of path.join API.
Impact:
This vulnerability affects all users in active release lines: 18.x, 20.x, 22.x, 23.x
Thank you, to ryotak and taise for reporting this vulnerability and thank you tniessen for fixing it.
GOAWAY HTTP/2 frames cause memory leak outside heap (CVE-2025-23085) - (medium)
A memory leak could occur when a remote peer abruptly closes the socket without sending a GOAWAY notification. Additionally, if an invalid header was detected by nghttp2, causing the connection to be terminated by the peer, the same leak was triggered. This flaw could lead to increased memory consumption and potential denial of service under certain conditions.
This vulnerability affects HTTP/2 Server users on Node.js v18.x, v20.x, v22.x and v23.x.
Impact:
This vulnerability affects all users in active release lines: 18.x, 20.x, 22.x, 23.x
Thank you, to newtmitch for reporting this vulnerability and thank you RafaelGSS for fixing it.
Downloads and release details
Node.js v18.20.6
Node.js v20.18.2
Node.js v22.13.1
Node.js v23.6.1
Summary
The Node.js project will release new versions of the 23.x, 22.x, 20.x, 18.x
releases lines on or shortly after, Tuesday, January 21, 2025 in order to address:
1 high severity issues.
2 medium severity issues.
Impact
The 23.x release line of Node.js is vulnerable to 1 high severity issues, 2 medium severity issues.
The 22.x release line of Node.js is vulnerable to 1 high severity issues, 2 medium severity issues.
The 20.x release line of Node.js is vulnerable to 1 high severity issues, 2 medium severity issues.
The 18.x release line of Node.js is vulnerable to 2 medium severity issues.
It&#x27;s important to note that End-of-Life versions are always affected when a security release occurs.
To ensure your system&#x27;s security, please use an up-to-date version as outlined in our
Release Schedule .
Release timing
Releases will be available on, or shortly after, Tuesday, January 21, 2025.
Contact and future updates
The current Node.js security policy can be found at https://nodejs.org/en/security/ .
Please follow the process outlined in https://github.com/nodejs/node/blob/master/SECURITY.md if you wish to report a vulnerability in Node.js.
Subscribe to the low-volume announcement-only nodejs-sec mailing list at https://groups.google.com/forum/#!forum/nodejs-sec to stay up to date on security vulnerabilities and security-related releases of Node.js and the projects maintained in the nodejs GitHub organization. Previous Updates on CVE for End-of-Life Versions Next Upcoming CVE for End-of-Life Node.js Versions

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
