---
id: "GHSA-w5r9-j49j-2m55"
kind: "vulnerability"
aliases: ["GHSA-w5r9-j49j-2m55"]
title: "Duplicate Advisory : Flowise has arbitrary file access due to missing chat flow id validation"
severity: "critical"
cvss: 9.8
epss: null
exploited: false
status: "withdrawn"
category: "ai-tooling"
products: [{"name": "flowise", "fixed": ["3.0.6"], "affected": ">= 2.2.8, < 3.0.6", "ecosystem": "npm"}]
ecosystems: ["npm"]
tags: ["ai-agents", "ai-tooling", "cwe-73", "flowise", "npm", "self-hosted"]
not_affected_if: ["no-internet-exposure", "version-3.0.6-or-later"]
published_at: "2026-06-26T00:32:05+00:00"
first_seen_at: "2026-11-03T17:36:46+00:00"
updated_at: "2026-11-03T17:38:31+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-w5r9-j49j-2m55", "first_seen_at": "2026-11-03T17:36:46+00:00"}]
---

# Duplicate Advisory : Flowise has arbitrary file access due to missing chat flow id validation

Flowise accepts path-traversal values as chatflow and chat IDs, so file handling reads and writes outside its storage folder. An unauthenticated attacker can read arbitrary files and write files, which may lead to remote code execution.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- npm:flowise affected >= 2.2.8, < 3.0.6 fixed 3.0.6

## How to check

- Check the installed version with `npm ls flowise` and see whether it is `2.2.8` or earlier
- Check whether the Flowise server is reachable from the internet at its `/api/v1/chatflows` and `/api/v1/get-upload-file` endpoints
- This advisory is withdrawn as a duplicate; the original is GHSA-q67q-549q-p849

## Fix

- flowise: upgrade to `3.0.6` or later

## Timeline

- 2026-11-03T17:36:46+00:00 ghsa https://github.com/advisories/GHSA-w5r9-j49j-2m55

## From the sources

### Duplicate Advisory
This advisory has been withdrawn because it is a duplicate of GHSA-q67q-549q-p849. This link is maintained to preserve external references.

### Original Description

Flowise before 3.0.6 (affected versions 2.2.8 and earlier) contains an arbitrary file access vulnerability due to missing validation that the chatflowId and chatId parameters are UUIDs or numbers in file handling operations. By supplying a path-traversal value (e.g., '../../../../../tmp') as the chatflow id, an unauthenticated attacker can use the /api/v1/chatflows endpoint (via addBase64FilesToStorage) to write arbitrary files, and the /api/v1/get-upload-file and /api/v1/openai-assistants-file/download endpoints (via streamStorageFile) to read arbitrary files. Arbitrary file write may lead to remote code execution.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
