{"id":"CVE-2026-96767","kind":"vulnerability","aliases":["CVE-2026-96767"],"related":[],"title":"NEX-Forms WordPress plugin: unauthenticated stored script injection via type parameter","description":"The NEX-Forms – Ultimate Forms Plugin for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'type' parameter in all versions up to, and including, 9.3.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","summary":"NEX-Forms (WordPress) <= 9.3.2 fails to sanitize the 'type' parameter, letting an unauthenticated attacker store script that runs when a user opens the injected page. Any WordPress site with the plugin active at <= 9.3.2 should be checked; sites without it or on 9.3.3+ can skip. Fixed in 9.3.3.","severity":"high","cvss":7.2,"epss":null,"exploited":false,"exploited_at":null,"products":[{"name":"nex-forms-express-wp-form-builder","fixed":["9.3.3"],"affected":"<= 9.3.2","ecosystem":"wordpress"}],"ecosystems":[],"tags":["nex-forms","package","unauthenticated","wordpress","wordpress-plugin","xss"],"not_affected_if":["patched-9.3.3","plugin-not-installed"],"how_to_check":"In WordPress admin > Plugins, check the NEX-Forms version; affected if <= 9.3.2. Or run: wp plugin get nex-forms-express-wp-form-builder --field=version","fix":"Update NEX-Forms (nex-forms-express-wp-form-builder) to 9.3.3 or later.","status":"open","published_at":"2026-10-29T12:17:14+00:00","first_seen_at":"2026-10-29T12:24:39+00:00","triaged_at":"2026-10-29T12:25:31+00:00","updated_at":"2026-10-29T12:27:12+00:00","category":"package","confidence":0.7,"triage":{"at":"2026-10-29T12:25:31Z","model":"claude-haiku-5-5","output":{"fix":"unknown","reach":"internet","title":"NEX-Forms WordPress plugin: unauthenticated stored script injection via type parameter","impact":"medium","summary":"NEX-Forms, a WordPress form plugin, fails to sanitize the 'type' parameter in all versions up to and including 9.3.2. An unauthenticated attacker can plant scripts that run in the browser of any user who opens the injected page.","audience":"businesses","category":"package","nicknames":[],"who_cares":["wordpress","nex-forms"],"confidence":0.7,"fix_status":"unknown","needs_auth":"no","worst_case":"scripts run in visitors' browsers, stealing sessions or admin actions","analyst_note":"Confirm the fixed plugin version and whether the 'type' parameter is exposed by default, using the NVD entry at https://nvd.nist.gov/vuln/detail/CVE-2026-96767 and the WordPress plugin changelog.","how_to_check":"- Check the installed NEX-Forms plugin version in the WordPress admin under Plugins; affected versions are up to and including `9.3.2`.\n- unknown","plain_action":"","needs_analyst":true,"not_affected_if":["plugin-not-installed"],"who_is_affected":"Sites running the NEX-Forms plugin for WordPress at version 9.3.2 or earlier are exposed, since the flaw is reachable without logging in. Sites that do not use this plugin are not affected. The sources do not state a fixed version.","user_interaction":"yes","needs_special_setup":"unknown","severity_if_unknown":"high"},"cost_usd":0.000696,"input_tokens":4183,"output_tokens":556,"severity_before":"high"},"analyst_status":"done","analyst_note":"Confirm the fixed plugin version and whether the 'type' parameter is exposed by default, using the NVD entry at https://nvd.nist.gov/vuln/detail/CVE-2026-96767 and the WordPress plugin changelog.","search":"'-2026':14A,17A '-96767':15A,18A '9.3.2':40B,70B,116C '9.3.3':79B,84B 'access':145C 'activ':68B 'arbitrari':134C 'attack':50B,131C 'builder':25A 'check':73B 'cross':102C 'cross-sit':101C 'cve':13A,16A 'due':117C 'escap':124C 'execut':141C 'express':22A 'fail':41B 'fix':82B 'form':3A,24A,28B,38B,88C,90C 'forms':21A 'includ':115C 'inject':9A,60B,133C,147C 'input':120C 'insuffici':119C 'let':47B 'make':126C 'nex':2A,20A,27B,37B,87C 'nex-form':1A,26B,36B,86C 'nex-forms-express-wp-form-builder':19A 'open':58B 'output':123C 'packag':29B 'page':61B,138C,148C 'paramet':12A,46B,108C 'plugin':5A,34B,67B,91C,94C 'possibl':128C 'run':54B 'sanit':43B,121C 'script':8A,52B,104C,136C 'site':64B,74B,103C 'skip':81B 'store':7A,51B,100C 'type':11A,45B,107C 'ultim':89C 'unauthent':6A,30B,49B,130C 'user':57B,144C 'version':111C 'via':10A,105C 'vulner':98C 'web':135C 'whenev':142C 'without':75B 'wordpress':4A,31B,33B,39B,63B,93C,96C 'wordpress-plugin':32B 'wp':23A 'xss':35B","nicknames":[],"mitigations":[],"who_affected":"Sites running the NEX-Forms plugin for WordPress at version 9.3.2 or earlier are exposed, since the flaw is reachable without logging in. Sites that do not use this plugin are not affected. The sources do not state a fixed version.","tier":"B","verified":{},"analyst_revisit_at":null,"fix_status":"none","audience":"businesses","plain_action":null,"first_public_at":"2026-10-29T12:17:14+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","cvss_by":"security@wordfence.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-96767","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-96767","severity":null,"published_at":"2026-10-29T12:17:14+00:00","modified_at":"2026-10-29T12:17:14+00:00","first_seen_at":"2026-10-29T12:24:39+00:00","fetched_at":"2026-10-29T12:24:39+00:00","note":null},{"source":"analyst","external_id":"CVE-2026-96767:1021","url":null,"severity":null,"published_at":"2026-10-29T12:27:12+00:00","modified_at":"2026-10-29T12:27:12+00:00","first_seen_at":"2026-10-29T12:27:12+00:00","fetched_at":"2026-10-29T12:27:12+00:00","note":"Patchstack (third-party, linked) says <=9.3.2 unauth XSS, fixed 9.3.3, CVSS 7.1, mitigation rule exists; Wordfence CNA CVSS 7.2. Wordfence/NVD/wordpress.org changelog not retrievable, so nothing marked verified. Not known exploited. Whether 'type' is exposed by default is unconfirmed. WPSEC-2026-1306 (submission-data XSS, also fixed 9.3.3) may be related."}],"documents":[{"id":16413,"url":"https://patchstack.com/database/wordpress/plugin/nex-forms-express-wp-form-builder/vulnerability/wordpress-nex-forms-ultimate-forms-plugin-for-wordpress-plugin-9-3-2-unauthenticated-stored-cross-site-scripting-vulnerability","title":"Patchstack: NEX-Forms <= 9.3.2 unauthenticated stored XSS (CVE-2026-96767)","kind":"advisory","source":"analyst","publisher":null,"text":null,"published_at":null,"relation":"advisory","confidence":null,"note":null}],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}