---
id: "CVE-2026-95753"
kind: "vulnerability"
aliases: ["CVE-2026-95753"]
title: "HPE Fabric Composer API flaw lets a low-privilege user view network traffic from managed switches"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "fabric-composer", "fixed": ["7.3.5", "7.4.1"], "affected": "<= 7.3.4, <= 7.4.0", "ecosystem": "vendor"}]
ecosystems: []
tags: ["fabric-composer", "hpe", "infrastructure", "network-switches", "self-hosted"]
not_affected_if: ["auth-required", "no-fabric-composer"]
published_at: "2026-11-03T20:18:23+00:00"
first_seen_at: "2026-11-03T20:49:26+00:00"
updated_at: "2026-11-03T20:53:28+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-95753", "first_seen_at": "2026-11-03T20:49:26+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-11-03T20:53:28+00:00"}]
---

# HPE Fabric Composer API flaw lets a low-privilege user view network traffic from managed switches

CVE-2026-95753 (CVSS 7.1) is a flaw in the HPE Networking Fabric Composer API. An authenticated attacker with low privileges could view network traffic from switches that Fabric Composer manages. HPE found it internally and is not aware of public discussion or exploit code. Fixed in 7.4.1 and 7.3.5.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:fabric-composer affected <= 7.3.4, <= 7.4.0 fixed 7.3.5, 7.4.1

## How to check

Check the installed Fabric Composer version. Versions 7.4.0 and below, and 7.3.4 and below, are affected; fixed in 7.4.1+ and 7.3.5+. Releases past End of Maintenance/Support are presumed affected. Until patched, HPE recommends restricting CLI and web management interfaces to a dedicated layer 2 segment/VLAN and/or firewall policies at layer 3 and above, with accounting controls logging user activity.

## Fix

Upgrade HPE Networking Fabric Composer to 7.4.1 or later (7.4.x branch) or 7.3.5 or later (7.3.x branch); download from the HPE Networking Support Portal.

## Timeline

- 2026-11-03T20:49:26+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-95753
- 2026-11-03T20:53:28+00:00 analyst — Read HPE advisory HPESBNW05172 (2026-11-03, csaf text; entry for this CVE read via WebFetch summary since web-cli output truncated before it). Affected 7.4.0 and below, 7.3.4 and below; fixed 7.4.1+, 7.3.5+. No exploitation or public PoC known to HPE. No public posts checked (just published). Workaround is only in how-to-check (no workaround flag).

## Documents

- [advisory] HPESBNW05172 rev.1 - Multiple Vulnerabilities in HPE Networking Fabric Composer (AFC) https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt
- [mentions] OffSeq: CVE-2026-95753 https://radar.offseq.com/threat/cve-2026-95753-privilege-escalation-in-hpe-networking-fabric-composer-api-4765688abaf348ab

## From the sources

A privilege escalation vulnerability exists in the API of HPE Networking Fabric Composer. Successful exploitation could allow an authenticated attacker with low privileges to disclose network traffic from switches managed by Fabric Composer.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
