---
id: "CVE-2026-95752"
kind: "vulnerability"
aliases: ["CVE-2026-95752"]
title: "HPE Networking Fabric Composer: local user can gain higher privileges"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "Fabric Composer", "fixed": ["7.4.1", "7.3.5"], "affected": "<= 7.4.0, <= 7.3.4", "ecosystem": "vendor"}]
ecosystems: []
tags: ["hpe-networking-fabric-composer", "infrastructure", "network-management"]
not_affected_if: ["no-local-users"]
published_at: "2026-11-03T20:18:23+00:00"
first_seen_at: "2026-11-03T20:49:26+00:00"
updated_at: "2026-11-03T20:53:04+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-95752", "first_seen_at": "2026-11-03T20:49:26+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-11-03T20:53:04+00:00"}]
---

# HPE Networking Fabric Composer: local user can gain higher privileges

A flaw in the API of HPE Networking Fabric Composer lets a low-privileged local user raise their privileges on the system. An attacker who already has a local account can gain administrative control of the affected host.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:Fabric Composer affected <= 7.4.0, <= 7.3.4 fixed 7.4.1, 7.3.5

## How to check

Check the installed Fabric Composer version; versions 7.4.0 and below, or 7.3.4 and below, are affected (7.4.x needs 7.4.1+, 7.3.x needs 7.3.5+). End-of-support branches were not assessed by HPE and should be treated as potentially affected.

## Fix

Upgrade HPE Networking Fabric Composer to 7.4.1 or later (7.4.x) or 7.3.5 or later (7.3.x); download from the HPE Networking Support Portal.

## Timeline

- 2026-11-03T20:49:26+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-95752
- 2026-11-03T20:53:04+00:00 analyst — Read HPE advisory HPESBNW05172 (Nov 3 2026, CSAF text): affected 7.4.0 and below, 7.3.4 and below; fixed 7.4.1+, 7.3.5+; no known exploit/PoC; workaround restrict mgmt interfaces.

## Documents

- [advisory] HPESBNW05172 rev.1 - Multiple Vulnerabilities in HPE Networking Fabric Composer (AFC) https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt

## From the sources

A local privilege escalation vulnerability exists in the API of HPE Networking Fabric Composer. Successful exploitation could allow a low-privileged local attacker to elevate their privileges on the affected system.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
