---
id: "CVE-2026-95748"
kind: "vulnerability"
aliases: ["CVE-2026-95748"]
title: "HPE Networking Fabric Composer: SQL injection lets an attacker run database commands"
severity: "high"
cvss: 7.5
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "fabric-composer", "fixed": ["7.3.5", "7.4.1"], "affected": "<= 7.3.4, <= 7.4.0", "ecosystem": "vendor"}]
ecosystems: []
tags: ["fabric-composer", "hpe", "infrastructure", "network-management", "networking-fabric-composer", "self-hosted"]
not_affected_if: ["no-fabric-composer", "not-installed"]
published_at: "2026-11-03T20:18:23+00:00"
first_seen_at: "2026-11-03T20:49:25+00:00"
updated_at: "2026-11-03T20:55:01+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-95748", "first_seen_at": "2026-11-03T20:49:25+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-11-03T20:55:01+00:00"}]
---

# HPE Networking Fabric Composer: SQL injection lets an attacker run database commands

HPE Networking Fabric Composer has a SQL injection flaw that lets an attacker send crafted input that is run as database commands. The attacker needs no account and must be on an adjacent network segment.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:fabric-composer affected <= 7.3.4, <= 7.4.0 fixed 7.3.5, 7.4.1

## How to check

Check the installed Fabric Composer version: 7.4.0 and below, and 7.3.4 and below, are affected; fixed in 7.4.1+ and 7.3.5+. Versions past End of Maintenance/Support are presumed affected. Until patched, HPE recommends restricting the CLI and web management interfaces to a dedicated layer 2 segment/VLAN and/or firewall policies at layer 3 and above, with accounting controls.

## Fix

Upgrade HPE Networking Fabric Composer to 7.4.1 or later (7.4.x) or 7.3.5 or later (7.3.x); download from the HPE Networking Support Portal.

## Timeline

- 2026-11-03T20:49:25+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-95748
- 2026-11-03T20:55:01+00:00 analyst — Read HPE HPESBNW05172 (2026-11-03): affected 7.4.0 and below, 7.3.4 and below; fixed 7.4.1+ / 7.3.5+. Entry 95748 read via WebFetch summary (CVSS 7.5, AV:A/AC:H/PR:N, VULN-1018). HPE not aware of public discussion or exploit. No posts checked, just published.

## Documents

- [advisory] HPESBNW05172 rev.1 - Multiple Vulnerabilities in HPE Networking Fabric Composer (AFC) https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt

## From the sources

A SQL injection vulnerability exists in HPE Networking Fabric Composer. Successful exploitation could allow an unauthenticated adjacent attacker to run arbitrary database commands.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
