---
id: "CVE-2026-95741"
kind: "vulnerability"
aliases: ["CVE-2026-95741"]
title: "HPE Networking Fabric Composer: API missing integrity verification lets low-privilege users gain elevated privileges"
severity: "high"
cvss: 8.0
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "HPE Networking Fabric Composer", "fixed": ["7.3.5", "7.4.1"], "affected": "<= 7.3.4, 7.4.0", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api", "hpe", "infrastructure", "networking-fabric-composer", "privilege-escalation", "self-hosted"]
not_affected_if: ["auth-required", "product-not-deployed"]
published_at: "2026-11-03T20:18:22+00:00"
first_seen_at: "2026-11-03T20:49:25+00:00"
updated_at: "2026-11-03T20:56:17+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-95741", "first_seen_at": "2026-11-03T20:49:25+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-11-03T20:56:17+00:00"}]
---

# HPE Networking Fabric Composer: API missing integrity verification lets low-privilege users gain elevated privileges

HPE says the Fabric Composer API lacks an integrity verification check, so an authenticated low-privileged attacker can gain elevated privileges. Fixed in 7.4.1 and 7.3.5. HPE found it internally and knows of no public discussion or exploit code. HPE's workaround: restrict CLI and web management interfaces to a dedicated layer 2 segment/VLAN and/or firewall policies, with accounting controls.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:HPE Networking Fabric Composer affected <= 7.3.4, 7.4.0 fixed 7.3.5, 7.4.1

## How to check

Check the installed Fabric Composer version. Affected: 7.4.x up to 7.4.0 and 7.3.x up to 7.3.4 (older end-of-maintenance releases are presumed affected). Also check who can reach the management API and CLI.

## Fix

Upgrade to Fabric Composer 7.4.1 or later (7.4.x) or 7.3.5 or later (7.3.x); download from the HPE Networking Support Portal.

## Timeline

- 2026-11-03T20:49:25+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-95741
- 2026-11-03T20:56:17+00:00 analyst — Found in HPE advisory HPESBNW05172 (2026-11-03): CVE-2026-95741, missing integrity verification in AFC API, High, low-priv authenticated. Affected 7.4.0 and below / 7.3.4 and below; fixed 7.4.1 / 7.3.5. No exploit known per HPE. CVSS score and API-default-exposure not read (page truncated); not stated.

## Documents

- [advisory] HPESBNW05172 rev.1 - Multiple Vulnerabilities in HPE Networking Fabric Composer (AFC) https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt

## From the sources

A missing integrity verification vulnerability exists in the API of HPE Networking Fabric Composer. Successful exploitation could allow a low-privileged authenticated attacker to gain elevated privileges on the affected system.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
