{"id":"CVE-2026-95741","kind":"vulnerability","aliases":["CVE-2026-95741"],"related":[],"title":"HPE Networking Fabric Composer: API missing integrity verification lets low-privilege users gain elevated privileges","description":"A missing integrity verification vulnerability exists in the API of HPE Networking Fabric Composer. Successful exploitation could allow a low-privileged authenticated attacker to gain elevated privileges on the affected system.","summary":"HPE says the Fabric Composer API lacks an integrity verification check, so an authenticated low-privileged attacker can gain elevated privileges. Fixed in 7.4.1 and 7.3.5. HPE found it internally and knows of no public discussion or exploit code. HPE's workaround: restrict CLI and web management interfaces to a dedicated layer 2 segment/VLAN and/or firewall policies, with accounting controls.","severity":"high","cvss":8.0,"epss":null,"exploited":false,"exploited_at":null,"products":[{"name":"HPE Networking Fabric Composer","fixed":["7.3.5","7.4.1"],"affected":"<= 7.3.4, 7.4.0","ecosystem":"vendor"}],"ecosystems":[],"tags":["api","hpe","infrastructure","networking-fabric-composer","privilege-escalation","self-hosted"],"not_affected_if":["auth-required","product-not-deployed"],"how_to_check":"Check the installed Fabric Composer version. Affected: 7.4.x up to 7.4.0 and 7.3.x up to 7.3.4 (older end-of-maintenance releases are presumed affected). Also check who can reach the management API and CLI.","fix":"Upgrade to Fabric Composer 7.4.1 or later (7.4.x) or 7.3.5 or later (7.3.x); download from the HPE Networking Support Portal.","status":"open","published_at":"2026-11-03T20:18:22+00:00","first_seen_at":"2026-11-03T20:49:25+00:00","triaged_at":"2026-11-03T20:49:57+00:00","updated_at":"2026-11-03T20:56:17+00:00","category":"infrastructure","confidence":0.85,"triage":{"at":"2026-11-03T20:49:57Z","model":"claude-haiku-5-5","output":{"fix":"unknown","reach":"network","title":"HPE Networking Fabric Composer: API integrity flaw lets low-privilege users gain more access","impact":"high","summary":"HPE Networking Fabric Composer's API does not verify the integrity of some data, so an attacker with a low-privilege account can escalate privileges on the affected system. The sources give no affected version range or fix.","audience":"businesses","category":"infrastructure","nicknames":[],"who_cares":["hpe","networking-fabric-composer","api"],"confidence":0.5,"fix_status":"unknown","needs_auth":"yes","worst_case":"low-privilege account gains elevated privileges on the system","analyst_note":"Find HPE's advisory for CVE-2026-95741 to get affected versions, fixed versions and whether the API is exposed by default.","how_to_check":"unknown","plain_action":"","needs_analyst":true,"not_affected_if":["product-not-deployed"],"who_is_affected":"Organizations running HPE Networking Fabric Composer with its API reachable by authenticated low-privilege users are likely exposed. The sources do not name affected versions or configurations, so the exact scope is unknown. Teams not running this product can skip it.","user_interaction":"no","needs_special_setup":"unknown","severity_if_unknown":"high"},"cost_usd":0.000637,"input_tokens":4090,"output_tokens":455,"severity_before":"high"},"analyst_status":"done","analyst_note":"Find HPE's advisory for CVE-2026-95741 to get affected versions, fixed versions and whether the API is exposed by default.","search":"'-2026':18A,21A '-95741':19A,22A '2':93B '7.3.5':66B '7.4.1':64B 'account':99B 'affect':131C 'allow':118C 'and/or':95B 'api':5A,27B,45B,109C 'attack':57B,124C 'authent':53B,123C 'check':50B 'cli':84B 'code':79B 'compos':4A,33B,44B,114C 'composer':26A 'control':100B 'could':117C 'cve':17A,20A 'dedic':91B 'discuss':76B 'elev':15A,60B,127C 'escal':36B 'exist':106C 'exploit':78B,116C 'fabric':3A,25A,32B,43B,113C 'firewal':96B 'fix':62B 'found':68B 'gain':14A,59B,126C 'host':39B 'hpe':1A,23A,28B,40B,67B,80B,111C 'infrastructur':29B 'integr':7A,48B,103C 'interfac':88B 'intern':70B 'know':72B 'lack':46B 'layer':92B 'let':9A 'low':11A,55B,121C 'low-privileg':10A,54B,120C 'manag':87B 'miss':6A,102C 'network':2A,31B,112C 'networking':24A 'networking-fabric-compos':30B 'polici':97B 'privileg':12A,16A,35B,56B,61B,122C,128C 'privilege-escal':34B 'public':75B 'restrict':83B 'say':41B 'segment/vlan':94B 'self':38B 'self-host':37B 'success':115C 'system':132C 'user':13A 'verif':8A,49B,104C 'vulner':105C 'web':86B 'workaround':82B","nicknames":[],"mitigations":[],"who_affected":"Anyone running HPE Networking Fabric Composer (AFC) 7.4.0 or earlier, or 7.3.4 or earlier, where a low-privileged account can reach the API. It needs a valid login first, so risk is highest where operator accounts are shared or the management interface is broadly reachable. Teams not running Fabric Composer can skip it.","tier":"B","verified":{"fix":{"at":"2026-11-03T20:56:17Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt","run_id":1544},"products":{"at":"2026-11-03T20:56:17Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt","run_id":1544},"how_to_check":{"at":"2026-11-03T20:56:17Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt","run_id":1544},"who_affected":{"at":"2026-11-03T20:56:17Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt","run_id":1544}},"analyst_revisit_at":null,"fix_status":"available","audience":"businesses","plain_action":null,"pkeys":["hpenetworkingfabriccomposer","networkingfabriccomposer"],"ptokens":["composer","fabric","hpe","networking"],"labels":["api","high","hpe","infrastructure","networkingfabriccomposer","privilegeescalation","selfhosted"],"campaign_type":null,"first_public_at":"2026-11-03T20:18:22+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","cvss_by":"security-alert@hpe.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-95741","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-95741","severity":null,"published_at":"2026-11-03T20:18:22+00:00","modified_at":"2026-11-03T20:30:24+00:00","first_seen_at":"2026-11-03T20:49:25+00:00","fetched_at":"2026-11-03T20:49:25+00:00","note":null},{"source":"analyst","external_id":"CVE-2026-95741:1544","url":null,"severity":null,"published_at":"2026-11-03T20:56:17+00:00","modified_at":"2026-11-03T20:56:17+00:00","first_seen_at":"2026-11-03T20:56:17+00:00","fetched_at":"2026-11-03T20:56:17+00:00","note":"Found in HPE advisory HPESBNW05172 (2026-11-03): CVE-2026-95741, missing integrity verification in AFC API, High, low-priv authenticated. Affected 7.4.0 and below / 7.3.4 and below; fixed 7.4.1 / 7.3.5. No exploit known per HPE. CVSS score and API-default-exposure not read (page truncated); not stated."}],"documents":[{"id":60639,"url":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05172.txt","title":"HPESBNW05172 rev.1 - Multiple Vulnerabilities in HPE Networking Fabric Composer (AFC)","kind":"advisory","source":"analyst","publisher":null,"text":null,"published_at":null,"relation":"advisory","confidence":null,"note":null}],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}