---
id: "CVE-2026-95728"
kind: "vulnerability"
aliases: ["CVE-2026-95728"]
title: "HPE Networking VIA client for Linux: arbitrary file write lets local users escalate privileges (fixed in 4.7.9)"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "other"
products: [{"name": "VIA client", "fixed": ["4.7.9"], "affected": "<= 4.7.8", "ecosystem": "vendor"}]
ecosystems: []
tags: ["endpoints", "hpe-aruba", "linux", "local-privilege-escalation", "other", "via-client", "vpn-client", "windows"]
not_affected_if: ["client-not-installed", "version-4.7.9-or-later"]
published_at: "2026-11-03T20:18:20+00:00"
first_seen_at: "2026-11-03T20:49:24+00:00"
updated_at: "2026-11-03T21:00:40+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-95728", "first_seen_at": "2026-11-03T20:49:24+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-11-03T21:00:40+00:00"}]
---

# HPE Networking VIA client for Linux: arbitrary file write lets local users escalate privileges (fixed in 4.7.9)

The Virtual Intranet Access (VIA) client has an arbitrary file write flaw. A local user with low privileges can write files anywhere they choose and use that to gain higher privileges on the machine.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:VIA client affected <= 4.7.8 fixed 4.7.9

## How to check

Check the installed VIA client version; 4.7.8 and below is affected. Advisory HPESBNW05173 lists the VIA client as affected on all platforms, but titles this CVE as Linux, so check Linux clients first and Windows/macOS clients too.

## Fix

Upgrade the HPE Networking VIA client to 4.7.9 or later (download from networkingsupport.hpe.com).

## Timeline

- 2026-11-03T20:49:24+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-95728
- 2026-11-03T21:00:40+00:00 analyst — Read HPE advisory HPESBNW05173 (CSAF txt): VIA client <=4.7.8 affected, fixed 4.7.9, no workaround, no known exploitation/public PoC. Triage tagged windows; vendor heading says Linux, affected list says all platforms. Reported by Lucid_Duck via bug bounty. CVSS 7.1. Not searched social: low-profile. Workaround: none per vendor.

## Documents

- [advisory] HPESBNW05173 rev.1 - Multiple Vulnerabilities in HPE Networking Virtual Intranet Access (VIA) https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt

## From the sources

An arbitrary file write vulnerability exists in the Virtual Intranet Access (VIA) client. Successful exploitation could allow a local attacker with low privileges to escalate privileges on the affected system.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
