{"id":"CVE-2026-95726","kind":"vulnerability","aliases":["CVE-2026-95726"],"related":[],"title":"HPE Networking VIA: buffer overflow lets unauthenticated attacker crash client","description":"A buffer overflow vulnerability in HPE Networking VIA could allow an unauthenticated remote attacker to conduct a denial of service attack. Successful exploitation could allow an attacker to interrupt the normal operation of the affected client.","summary":"A buffer overflow in HPE Networking VIA lets a remote attacker with no login interrupt normal operation of the affected client. The sources describe a denial of service, not code execution.","severity":"high","cvss":7.5,"epss":null,"exploited":false,"exploited_at":null,"products":[{"name":"VIA client","fixed":["4.7.9"],"affected":"<= 4.7.8","ecosystem":"vendor"}],"ecosystems":[],"tags":["denial-of-service","hpe-networking-via","infrastructure","vpn-client"],"not_affected_if":["not-installed","version-4.7.9-or-later"],"how_to_check":"Check the installed VIA client version on every platform; 4.7.8 and below is affected, 4.7.9 and above is fixed per HPESBNW05173. No workaround exists, so patching is the only remedy. HPE does not state which network path reaches the flaw, so treat any VIA client that connects to networks you do not control as exposed.","fix":"Upgrade HPE Networking VIA to 4.7.9 or later (download from networkingsupport.hpe.com).","status":"open","published_at":"2026-11-03T20:18:20+00:00","first_seen_at":"2026-11-03T20:49:24+00:00","triaged_at":"2026-11-03T20:50:10+00:00","updated_at":"2026-11-03T21:01:45+00:00","category":"infrastructure","confidence":0.85,"triage":{"at":"2026-11-03T20:50:10Z","model":"claude-haiku-5-5","output":{"fix":"unknown","reach":"network","title":"HPE Networking VIA: buffer overflow lets unauthenticated attacker crash client","impact":"low","summary":"A buffer overflow in HPE Networking VIA lets a remote attacker with no login interrupt normal operation of the affected client. The sources describe a denial of service, not code execution.","audience":"businesses","category":"infrastructure","nicknames":[],"who_cares":["hpe-networking-via","vpn-client"],"confidence":0.6,"fix_status":"unknown","needs_auth":"no","worst_case":"Remote attacker interrupts the client's normal operation, causing denial of service","analyst_note":"Confirm affected HPE Networking VIA versions and the fixed release from the HPE security bulletin; the NVD entry alone does not give ranges.","how_to_check":"- Check whether HPE Networking VIA client software is installed on endpoints\n- Compare the installed version against the HPE advisory for CVE-2026-95726\n- unknown for exact affected version ranges","plain_action":"","needs_analyst":true,"not_affected_if":["not-installed"],"who_is_affected":"Organizations running HPE Networking VIA clients. The sources do not list affected versions or the exact network conditions needed to reach the flaw.","user_interaction":"unknown","needs_special_setup":"unknown","severity_if_unknown":"unknown"},"cost_usd":0.000653,"input_tokens":4109,"output_tokens":484,"severity_before":"high"},"analyst_status":"done","analyst_note":"Confirm affected HPE Networking VIA versions and the fixed release from the HPE security bulletin; the NVD entry alone does not give ranges.","search":"'-2026':12A,15A '-95726':13A,16A 'affect':50B,96C 'allow':71C,86C 'attack':8A,41B,75C,82C,88C 'buffer':4A,32B,63C 'client':10A,18A,30B,51B,97C 'code':60B 'conduct':77C 'could':70C,85C 'crash':9A 'cve':11A,14A 'denial':20B,56B,79C 'denial-of-servic':19B 'describ':54B 'execut':61B 'exploit':84C 'hpe':1A,24B,35B,67C 'hpe-networking-via':23B 'infrastructur':27B 'interrupt':45B,90C 'let':6A,38B 'login':44B 'network':2A,25B,36B,68C 'normal':46B,92C 'oper':47B,93C 'overflow':5A,33B,64C 'remot':40B,74C 'servic':22B,58B,81C 'sourc':53B 'success':83C 'unauthent':7A,73C 'via':3A,17A,26B,37B,69C 'vpn':29B 'vpn-client':28B 'vulner':65C","nicknames":[],"mitigations":[],"who_affected":"Any machine running the HPE Networking (Aruba) Virtual Intranet Access (VIA) VPN client version 4.7.8 or below, on all platforms. An unauthenticated remote attacker could crash the client through a buffer overflow; HPE describes denial of service only, with no code execution stated. Machines without the VIA client, or on 4.7.9 or later, can skip it.","tier":"B","verified":{"fix":{"at":"2026-11-03T21:01:45Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt","run_id":1555},"products":{"at":"2026-11-03T21:01:45Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt","run_id":1555},"workarounds":{"at":"2026-11-03T21:01:45Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt","run_id":1555},"how_to_check":{"at":"2026-11-03T21:01:45Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt","run_id":1555},"who_affected":{"at":"2026-11-03T21:01:45Z","by":"analyst","doc":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt","run_id":1555}},"analyst_revisit_at":null,"fix_status":"available","audience":"businesses","plain_action":null,"pkeys":["client","viaclient"],"ptokens":["client","via"],"labels":["denialofservice","high","hpenetworkingvia","infrastructure","vpnclient"],"campaign_type":null,"first_public_at":"2026-11-03T20:18:20+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","cvss_by":"security-alert@hpe.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-95726","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-95726","severity":null,"published_at":"2026-11-03T20:18:20+00:00","modified_at":"2026-11-03T20:30:24+00:00","first_seen_at":"2026-11-03T20:49:24+00:00","fetched_at":"2026-11-03T20:49:24+00:00","note":null},{"source":"analyst","external_id":"CVE-2026-95726:1555","url":null,"severity":null,"published_at":"2026-11-03T21:01:45+00:00","modified_at":"2026-11-03T21:01:45+00:00","first_seen_at":"2026-11-03T21:01:45+00:00","fetched_at":"2026-11-03T21:01:45+00:00","note":"Read HPE advisory HPESBNW05173 (CSAF txt): VIA client all platforms <=4.7.8 affected, fixed 4.7.9, no workaround. HPE found it internally, no known public discussion or exploit code. Advisory does not name the attack path. X/social not searched; low-profile."}],"documents":[{"id":60672,"url":"https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt","title":"HPESBNW05173 rev.1 - Multiple Vulnerabilities in HPE Networking Virtual Intranet Access (VIA)","kind":"advisory","source":"analyst","publisher":null,"text":null,"published_at":null,"relation":"advisory","confidence":null,"note":null}],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}