---
id: "CVE-2026-95725"
kind: "vulnerability"
aliases: ["CVE-2026-95725"]
title: "HPE Networking VIA client for Linux: command injection lets local users run commands with elevated privileges (fixed in 4.7.9)"
severity: "high"
cvss: 7.8
epss: null
exploited: false
status: "open"
category: "other"
products: [{"name": "VIA client", "fixed": ["4.7.9"], "affected": "<= 4.7.8", "ecosystem": "vendor"}]
ecosystems: []
tags: ["hpe-aruba", "linux", "local-privilege-escalation", "other", "via-client", "vpn-client"]
not_affected_if: ["client-not-installed", "version-4.7.9-or-later"]
published_at: "2026-11-03T20:18:20+00:00"
first_seen_at: "2026-11-03T20:49:24+00:00"
updated_at: "2026-11-03T21:01:35+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-95725", "first_seen_at": "2026-11-03T20:49:24+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-11-03T21:01:35+00:00"}]
---

# HPE Networking VIA client for Linux: command injection lets local users run commands with elevated privileges (fixed in 4.7.9)

The VIA client for Linux has a command injection flaw. A low-privileged local user can run arbitrary commands with elevated privileges on the affected system.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:VIA client affected <= 4.7.8 fixed 4.7.9

## How to check

Check the installed VIA client version; 4.7.8 and below is affected per HPE advisory HPESBNW05173. The CVE entry is titled for the Linux client, while the advisory's affected-products list says all platforms, so check Linux first and also check Windows/macOS clients.

## Fix

Upgrade the HPE Networking VIA client to 4.7.9 or later (download from networkingsupport.hpe.com).

## Timeline

- 2026-11-03T20:49:24+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-95725
- 2026-11-03T21:01:35+00:00 analyst — Read HPE advisory HPESBNW05173 (same one as sibling CVE-2026-95728): VIA client <=4.7.8 affected, fixed 4.7.9, no workaround, no known exploitation or public PoC. Reported by m0omo0d via bug bounty. CVSS 7.8. Per-CVE detail gives no trigger mechanics. Social not searched, low profile.

## Documents

- [advisory] HPESBNW05173 rev.1 - Multiple Vulnerabilities in HPE Networking Virtual Intranet Access (VIA) https://csaf.arubanetworking.hpe.com/2026/hpe_networking_-_hpesbnw05173.txt

## From the sources

A command injection vulnerability exists in the VIA client for Linux. Successful exploitation could allow a low-privileged local attacker to execute arbitrary commands with elevated privileges on the affected system.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
