---
id: "CVE-2026-93680"
kind: "vulnerability"
aliases: ["CVE-2026-93680"]
title: "Langflow: improper authentication lets a remote attacker bypass security restrictions"
severity: "critical"
cvss: 9.8
epss: null
exploited: false
status: "open"
category: "ai-tooling"
products: []
ecosystems: []
tags: ["ai-apps", "ai-tooling", "langflow", "self-hosted"]
not_affected_if: ["versions-outside-1.0.0-to-1.12.8"]
published_at: "2026-10-29T16:20:06+00:00"
first_seen_at: "2026-10-29T16:26:03+00:00"
updated_at: "2026-10-29T16:27:12+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-93680", "first_seen_at": "2026-10-29T16:26:03+00:00"}]
---

# Langflow: improper authentication lets a remote attacker bypass security restrictions

IBM Langflow OSS versions 1.0.0 through 1.12.8 fail to properly check authentication, so a remote attacker can bypass security restrictions. The sources do not say what the attacker can reach after the bypass.

_Summary, check and fix written by a model from the sources; labelled as such._

## How to check

- Check the installed Langflow version, for example with `pip show langflow`, and compare it to the affected range 1.0.0 through 1.12.8.

## Fix

- Langflow OSS: a fixed version above `1.12.8` is implied by the affected range, but the sources do not name it.

## Timeline

- 2026-10-29T16:26:03+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-93680

## From the sources

IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to bypass security restrictions due to improper authentication.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
