---
id: "CVE-2026-66274"
kind: "vulnerability"
aliases: ["CVE-2026-66274", "GHSA-p2gc-fm5w-94jj"]
title: "Apache Qpid Proton-J: Unbounded type nesting can lead to pre-authentication stackoverflow"
severity: "high"
cvss: 7.5
epss: 0.00774
exploited: false
status: "open"
category: "package"
products: [{"name": "org.apache.qpid:proton-j", "fixed": ["0.35.0"], "affected": "< 0.35.0", "ecosystem": "maven"}, {"name": "apache qpid proton-j", "fixed": ["0.35.0"], "affected": "< 0.35.0", "ecosystem": "vendor"}]
ecosystems: ["maven", "vendor"]
tags: ["amqp", "cwe-674", "java", "maven", "messaging", "package"]
not_affected_if: ["no-untrusted-amqp-listener", "proton-j-0.35.0-or-later"]
published_at: "2026-08-05T07:16:37+00:00"
first_seen_at: "2026-11-03T21:35:15+00:00"
updated_at: "2026-11-03T22:07:19+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-p2gc-fm5w-94jj", "first_seen_at": "2026-11-03T21:35:15+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-66274", "first_seen_at": "2026-11-03T22:07:19+00:00"}]
---

# Apache Qpid Proton-J: Unbounded type nesting can lead to pre-authentication stackoverflow

Apache Qpid Proton-J, a Java library for the AMQP messaging protocol, does not limit how deeply AMQP types can be nested. A remote attacker can send a crafted message before authenticating to trigger a StackOverflowError, which can take the service down (denial of service).

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- maven:org.apache.qpid:proton-j affected < 0.35.0 fixed 0.35.0
- vendor:apache qpid proton-j affected < 0.35.0 fixed 0.35.0

## How to check

- Check the proton-j version in your build file or dependency tree (for example `mvn dependency:tree | grep proton-j`).
- Confirm whether a service using it accepts AMQP connections from untrusted networks.

## Fix

- `org.apache.qpid:proton-j` `0.35.0`

## Timeline

- 2026-11-03T21:35:15+00:00 ghsa https://github.com/advisories/GHSA-p2gc-fm5w-94jj
- 2026-11-03T22:07:19+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-66274

## Documents

- [advisory] Vendor advisory: lists.apache.org https://lists.apache.org/thread/h7xolzws2by2qhdjf7scbx87foxojb5h
- [advisory] Third-party advisory: www.openwall.com http://www.openwall.com/lists/oss-security/2026/08/04/10
- [fix] Patch: github.com https://github.com/apache/qpid-proton-j/commit/92047419cc87bab6220e7adeb354958d8109618e
- [fix] Release: github.com https://github.com/apache/qpid-proton-j/releases/tag/0.35.0

## From the sources

A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.

This issue affects Apache Qpid Proton-J: through 0.34.1.

Users are recommended to upgrade to version 0.35.0, which fixes the issue.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
