---
id: "CVE-2026-62016"
kind: "vulnerability"
aliases: ["CVE-2026-62016"]
title: "Gamic WordPress theme: unauthenticated PHP object injection lets attackers run code"
severity: "critical"
cvss: 9.8
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "Gamic - Gaming Metaverse Game & Crypto WordPress Theme (ThemeREX)", "fixed": [], "affected": "<= 1.19", "ecosystem": "wordpress-theme"}]
ecosystems: []
tags: ["gamic", "package", "php", "php-object-injection", "themerex", "wordpress", "wordpress-theme"]
not_affected_if: ["gamic-not-installed"]
published_at: "2026-10-29T16:18:14+00:00"
first_seen_at: "2026-10-29T16:26:00+00:00"
updated_at: "2026-10-29T16:28:13+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-62016", "first_seen_at": "2026-10-29T16:26:00+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-29T16:28:13+00:00"}]
---

# Gamic WordPress theme: unauthenticated PHP object injection lets attackers run code

Gamic versions 1.19 and earlier contain an unauthenticated PHP object injection flaw. An attacker who sends a crafted request can inject a PHP object that may lead to code execution on the server.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress-theme:Gamic - Gaming Metaverse Game & Crypto WordPress Theme (ThemeREX) affected <= 1.19 fixed ?

## How to check

- WordPress admin > Appearance > Themes: look for 'Gamic - Gaming Metaverse Game & Crypto' (active or inactive) and its version; or read 'Version:' in wp-content/themes/gamic/style.css
- Version 1.19 or lower is vulnerable; inactive installed themes can still be reachable, so delete it if unused
- WP-CLI: wp theme list

## Timeline

- 2026-10-29T16:26:00+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-62016
- 2026-10-29T16:28:13+00:00 analyst — Theme (not plugin), <=1.19, unauth PHP object injection CWE-502; Patchstack/WPScan say no official patch, no known POP chain in Gamic itself (RCE depends on other plugins/themes). Not exploited per sources. CVSS 9.8 (Patchstack) vs 8.1 (Wordfence/WPScan). A securityonline page lists 'patched 1.19', which contradicts these and looks wrong. No vendor (ThemeREX) page found, so nothing marked verified; fix none rests on Patchstack/WPScan. Mitigation: Patchstack virtual patch rule only; otherwise remove/replace the theme.

## Documents

- [advisory] Patchstack: WordPress Gamic Theme <= 1.19 PHP Object Injection https://patchstack.com/database/wordpress/theme/gamic/vulnerability/wordpress-gamic-theme-1-19-php-object-injection-vulnerability
- [advisory] WPScan: Gamic <= 1.19 Unauthenticated PHP Object Injection https://wpscan.com/vulnerability/ce7a0c53-26f7-418d-995e-96228dde0992/

## From the sources

Unauthenticated PHP Object Injection in Gamic <= 1.19 versions.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
