---
id: "CVE-2026-61995"
kind: "vulnerability"
aliases: ["CVE-2026-61995"]
title: "YouTube Showcase WordPress plugin: unauthenticated XSS through versions 4.1.0"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "youtube-showcase", "fixed": [], "affected": "<= 4.1.0", "ecosystem": "wordpress"}]
ecosystems: []
tags: ["emarket-design", "package", "wordpress", "xss", "youtube-showcase"]
not_affected_if: ["plugin-deactivated", "plugin-not-installed"]
published_at: "2026-10-29T16:18:12+00:00"
first_seen_at: "2026-10-29T16:25:59+00:00"
updated_at: "2026-10-29T16:35:59+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-61995", "first_seen_at": "2026-10-29T16:25:59+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-29T16:35:59+00:00"}]
---

# YouTube Showcase WordPress plugin: unauthenticated XSS through versions 4.1.0

YouTube Showcase versions up to and including 4.1.0 contain a cross site scripting flaw that needs no login. An attacker can get malicious script to run in a visitor's browser on a site that uses the plugin.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress:youtube-showcase affected <= 4.1.0 fixed ?

## How to check

WordPress admin > Plugins: look for 'Video Gallery – YouTube Gallery, Playlist & Video Grid' (slug youtube-showcase); version 4.1.0 or earlier is affected. 4.1.0 is currently the latest release on WordPress.org, so no fixed version exists yet.

## Fix

No fixed version known: Patchstack lists no official patch and the WordPress.org changelog's newest release is 4.1.0, the affected one. Deactivate or remove the plugin until a newer release appears.

## Timeline

- 2026-10-29T16:25:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-61995
- 2026-10-29T16:35:59+00:00 analyst — Patchstack (CNA) says <= 4.1.0, unauthenticated XSS, user interaction required, no patch; wp.org latest is 4.1.0. Vulnerable input not published. Vendor has not confirmed; nothing marked verified. Not exploited per sources. Recheck wp.org changelog for 4.1.1+.

## Documents

- [advisory] Patchstack: YouTube Showcase <= 4.1.0 XSS, no official patch https://patchstack.com/database/wordpress/plugin/youtube-showcase/vulnerability/wordpress-youtube-showcase-plugin-4-1-0-cross-site-scripting-xss-vulnerability
- [describes] YouTube Showcase on WordPress.org (changelog; latest 4.1.0) https://wordpress.org/plugins/youtube-showcase/

## From the sources

Unauthenticated Cross Site Scripting (XSS) in YouTube Showcase <= 4.1.0 versions.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
